Synology NAS - Backup naar C2 'failed' binnen 24h na initial backup

Gebruikersavatar
TimoLimo
Plus Member
Plus Member
Berichten: 178
Lid geworden op: 03 Mar 2010
Bedankt: 35 keer
Uitgedeelde bedankjes: 38 keer

Synology NAS - Backup naar C2 'failed' binnen 24h na initial backup

Berichtdoor TimoLimo » 28 Mar 2018, 12:30

Ik zit met het volgende irritante probleem:

TL;DR: C2 backup taken failen na een bepaalde tijd. Zoek manier om oorzaak te identificeren. Denk dat het komt door 'iets' dat poorten 443/5443 welke nodig zijn voor de backup de mist doen ingaan.

Long text:
Ik wil belangrijke bestanden backuppen naar de Synology C2 cloud dienst.
Dat werkt, maar vooral enkel manueel, niet automatisch.

Opzet:
- In Hyper Backup een Data backup taak gemaakt met de wizard (C2 service geselecteerd, er opent een popup om aan te loggen bij C2 om met een vinkje Hyper Backup te machtigen om er naar te backuppen)
- Folder(s) selecteren, encryptie paswoord instellen en private key backup downloaden, backup schedule inplannen (bv. dagelijks om 01u00), en dan de backup alvast manueel eens opstarten.

Hier gaat alles goed. Maar het blijft bij die initiële backup.
De volgende dag in de log: foutmelding 'Backup task failed' en de taak staat als failed in Hyper Backup. Van daaruit manueel een backup starten werkt ook niet meer. Gaat van status "initializing" naar "failed" (terwijl het naar "processing" zou moeten gaan en uiteindelijk 'succeeded')

Heb hier synology support voor gecontacteerd:
- gevraagde log files doorgestuurd
- Omdat er enkele third-party apps geïnstalleerd stonden, de vraag gekregen om die te deïnstalleren. Heb ze gedeactiveerd.
- Probleem bleef hetzelfde. Volgende actie dat Synology support me vroeg: volledige reset/reinstall van DSM. Heb ik vriendelijk voor bedankt en heb ze toch kunnen overtuigen om naar de volgende stappen te gaan.
- Gevraagd of ik de poorten 443 en 5443 (nodig voor de C2 backup service) kon testen met enkele CLI commando's: resultaat teruggestuurd en het zou mijn router zijn die alles blokkeert. Vond ik nogal raar, eerlijk gezegd, want alle uitgaande connecties worden automatisch inkomend toegestaan.
- Met tegengoesting poorten 443 en 5443 volledig opengezet van en naar de NAS op de router (Netgear R7000, zowel met port triggering als port forwarding): Probleem blijft
- Met tegengoesting hele NAS in DMZ gezet bij wijze van test (ik wil niet dat de NAS rechtstreeks op het internet zit, onmiddelijk was de firewall bezig met het blocken van ip's omdat ze aan het scannen waren): probleem blijft

Heb hetvolgende kunnen reconstrueren: Aanmaak nieuwe backup taak naar C2, dan werkt alles weer, ook de andere backup taak die voorheen steeds in Failed ging. Verwijderen van de backuptaken en opnieuw aanmaken: werkt ook weer. Gemene deler: telkens opnieuw aanloggen bij C2. Maar de volgende dag gaat alles weer in 'Failed'.

Dus ik dacht: misschien valt de link/connectie weg met de NAS en C2, of ten minste dat 443 en 5443 bij de NAS moeten terechtkomen waardoor de backup taak steeds in failed gaat?

Zo heb ik een hele resem backup-taken ingepland verspreid over 24u, allemaal naar C2 en telkens met 1 enkel test-foldertje om te syncen.
Alles blijft succesvol backuppen, BEHALVE ergens tussen 20u en 20u15 is er 'iets' dat de backuptaken opnieuw laat failed.

Het lijkt me alsof er dan 1 of ander process draait (of misschien ligt het probleem ergens anders op het netwerk?) dat ook poort 443 en/of 5443 gebruikt waardoor de C2 service ineens niet meer werkt of te benaderen is.

Zijn er voorstellen om te achterhalen/monitoren wat er dan juist gebeurd? Ik zit te denken in de richting van poorten in use, oplijsten welke processen welke poorten gebruiken, enz. Tenzij ik het echt in de verkeerde richting zit te zoeken?

Andere dingen die ik eens kan proberen? Alvast bedankt!

Gebruikersavatar
mailracer
Elite Poster
Elite Poster
Berichten: 2922
Lid geworden op: 23 Feb 2010
Bedankt: 230 keer
Recent bedankt: 4 keer
Uitgedeelde bedankjes: 177 keer

Re: Synology NAS - Backup naar C2 'failed' binnen 24h na initial backup

Berichtdoor mailracer » 28 Mar 2018, 12:43

443 word gebruikt voor HTTPS, dus kan het ook aan een SSL certificaat liggen. Mss ook in die richting zoeken :idea:

boran_blok
Premium Member
Premium Member
Berichten: 642
Lid geworden op: 09 Mar 2011
Bedankt: 49 keer
Uitgedeelde bedankjes: 13 keer

Re: Synology NAS - Backup naar C2 'failed' binnen 24h na initial backup

Berichtdoor boran_blok » 28 Mar 2018, 14:19

SSL doet me ook denken dat er eventueel wat van de nieuwere SSL protocollen niet ondersteund zouden zijn. TLS etc. Is dat deel van de nas up to date?

Gebruikersavatar
TimoLimo
Plus Member
Plus Member
Berichten: 178
Lid geworden op: 03 Mar 2010
Bedankt: 35 keer
Uitgedeelde bedankjes: 38 keer

Re: Synology NAS - Backup naar C2 'failed' binnen 24h na initial backup

Berichtdoor TimoLimo » 28 Mar 2018, 15:14

NAS is met alle componenten en DSM volledig up to date.

Zal vanavond nog eens kijken of ik iets met de certificaten kan doen.
Er is geen specifiek SSL certificaat opgezet voor HTTPS dus is alles het standaard synology.com certificaat (welke in browsers een cert foutmelding geeft, da's waar)
Ook kan ik voor een handvol apps een certificaat instellen in DSM, maar niet voor Hyper Backup (wel voor Hyper Backup Vault, maar dat is eigenlijk een ander programma, enkel als doelNAS voor backups en werkt ook op een andere poort?)

Zou niet weten wat ik aan SSL certificaten moet wijzigen, eerlijk gezegd? Aan welk domein moet het gekoppeld worden? Heb er wel al eentje van Let's Encrypt voor mijn dyndns domain dat de NAS zelf vernieuwd voor mijn VPN Server, maar dan nog? Zie niet in waarom ik dat voor andere services moet doen die ik enkel intern benader en niet via wan?

Update:

Denk dat ik het gevonden heb. heb eens in /var/log/messages gekeken (toevallig tegen gekomen, ben geen linux expert) of ik daar toch niet iets meer info kon terugvinden.
Daar staat hetvolgende:

Code: Selecteer alles

DiskStation img_backup: [4554]img_backup.cpp:2080 Cloud Backup Task has been started: task_ID: 15
DiskStation img_backup: [4554]img_backup.cpp:1969 Error: get temp file for /volume1/@img_bkp_cache/@eaDir/@tmp/mirror_folder.XXXXXX failed
DiskStation img_backup: [4554]img_backup.cpp:2114 failed to create mirror log folder for [/volume1/@img_bkp_cache/synocloud_swift__[...]]


@eaDir, die stomme iTunes folders die steevast door de synology mediaservice aanmaakt worden maar die je ziet staan bij browsen via NFS. Vond dat ergerlijk...
Ik heb dus een scriptje lopen die elke dag om 20u08 (!) alle @eaDir's gaat verwijderen op de hele folderstructuur........ :roll:
In de app CronJob Editor die ik altijd gebruik zie ik die background task niet staan, maar in de standaard DSM Task Scheduler dus wel. Was dat scriptje totaal vergeten wegens reeds aangemaakt bijna 5 jaar geleden...


Blijkt dat die Hyper Backup app overal @eaDir's loopt aan te maken, en jah, die worden dus opgezocht om 1 of andere reden. En als die niet bestaat, dan failed de backup task..

Nog eventjes afwachten of de scheduled jobs vanzelf nu goed lopen, maar dat zal het wel zijn.

Tot zover ook de kunde van de (Franse) Synology support dat dit log niet gelezen heeft.. Zou toch ook één van de eerste stappen moeten zijn? Soit, ik weet nu waar eerst kijken. Zal Synology wel mailen met de oorzaak.. (ALS de jobs niet meer failen ten minste :-D )

Cheers!


Terug naar “Computers en randapparatuur”

Wie is er online

Gebruikers op dit forum: Geen geregistreerde gebruikers en 3 gasten